Ticket #1028 (closed defect: fixed)

Opened 14 years ago

Last modified 14 years ago

user password widget inconsistency

Reported by: tziade Owned by: fguillaume
Priority: P2 Milestone: CPS 3.3.7
Component: CPSSchemas Version: TRUNK
Severity: normal Keywords:
Cc:

Description

if you get into a cps site and you set your password to "sspata" for example, the widget validates it, but next form validation wil say it's too short

Change History

comment:1 Changed 14 years ago by lregebro

  • Status changed from new to closed
  • Resolution set to fixed

No, it means that the password you provided next is too short. It is, since it is empty. ;)

The problem is that if the field is empty and required, and error is raised, otherwise all other checks are still performed. Having a minimun length thereby effectively makes a field required. Reasonably, if it is empty and not required, the rest of the checks can be skipped.

Checked in in revision [28508].

Note: See TracTickets for help on using tickets.