Ticket #1050 (closed defect: fixed)

Opened 14 years ago

Last modified 14 years ago

Theme optimizer propose the deletion of styles used by theme pages

Reported by: Olivier Grisel <olivier.grisel@…> Owned by: jmorliaguet
Priority: P3 Milestone: CPS 3.3.7
Component: CPSSkins Version: TRUNK
Severity: minor Keywords:
Cc:

Description

Theme optimizer propose the deletion of styles used by theme pages.

Steps to reproduce:

  • create a new area color style
  • use it on the theme page
  • optimize the theme

Change History

comment:1 Changed 14 years ago by jmorliaguet

I can't reproduce it. The theme optimizer asks to delete styles that are not used inside a theme.

are you sure you assigned it to some element?

comment:2 Changed 14 years ago by ogrisel

I can reprodoce it on a fresh trunk instance. The style (Area Color for instance) must be used only by a Theme Page element (by clicking on the page tab and selecting the style menu entry). Styles associated to page blocks or templets are not deleted by the optimizer, only style used by Theme Page elements.

comment:3 Changed 14 years ago by jmorliaguet

  • Status changed from new to assigned

this is in BaseStyle?.findParents(), the page's styles are not taken into account. This needs a refactoring anyway...

comment:4 Changed 14 years ago by jmorliaguet

  • Status changed from assigned to closed
  • Resolution set to fixed

can you check that this is fixed in [28571] ? I've added a test too.

comment:5 Changed 14 years ago by ogrisel

Your fix works, thanks.

Note: See TracTickets for help on using tickets.