Ticket #1079 (closed enhancement: duplicate)

Opened 14 years ago

Last modified 14 years ago

Add unit tests to check that there are no objects modified when a CPS site is read

Reported by: madarche Owned by: trac
Priority: P1 Milestone: CPS 3.3.7
Component: CPSDefault Version: TRUNK
Severity: normal Keywords:
Cc:

Description

Add unit tests to check that there are no objects modified when a CPS site is just read and not modified.

The ZODB should not be modified when a user is simply reading web pages and searching and not modifying documents and settings.

The tests could be written by checking that there isn't any objects to commit in a pre-commit hook.

Thoses tests should prevent performance regression.

Change History

comment:1 Changed 14 years ago by fguillaume

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #648.

Note: See TracTickets for help on using tickets.