Ticket #1135 (closed defect: fixed)

Opened 14 years ago

Last modified 14 years ago

Can't reset password

Reported by: fguillaume Owned by: fguillaume
Priority: P1 Milestone: CPS 3.4.0
Component: CPSUserFolder Version: 3.3.6
Severity: normal Keywords:
Cc:

Description (last modified by fguillaume) (diff)

2005-11-15T14:49:31 ERROR(200) SiteError http://intranet.nuxeo.com/account_reset_password
Traceback (most recent call last):
  File "/opt/Zope-2.7/lib/python/ZPublisher/Publish.py", line 101, in publish
    request, bind=1)
  File "/opt/Zope-2.7/lib/python/ZPublisher/mapply.py", line 88, in mapply
    if debug is not None: return debug(object,args,context)
  File "/opt/Zope-2.7/lib/python/ZPublisher/Publish.py", line 39, in call_object
    result=apply(object,args) # Type s<cr> to step into published object.
  File "/home/zopes/intranet.nuxeo/Products/CMFCore/FSPythonScript.py", line 108, in __call__
    return Script.__call__(self, *args, **kw)
  File "/opt/Zope-2.7/lib/python/Shared/DC/Scripts/Bindings.py", line 306, in __call__
    return self._bindAndExec(args, kw, None)
  File "/opt/Zope-2.7/lib/python/Shared/DC/Scripts/Bindings.py", line 343, in _bindAndExec
    return self._exec(bound_data, args, kw)
  File "/home/zopes/intranet.nuxeo/Products/CMFCore/FSPythonScript.py", line 163, in _exec
    result = f(*args, **kw)
  File "Script (Python)", line 18, in account_reset_password
  File "/home/zopes/intranet.nuxeo/Products/CPSDefault/MembershipTool.py", line 265, in resetPassword
    user.getRoles(), user.getDomains())
  File "/home/zopes/intranet.nuxeo/Products/CPSUserFolder/CPSUserFolder.py", line 476, in _doChangeUser
    dir.editEntry(entry)
  File "/home/zopes/intranet.nuxeo/Products/CPSDirectory/BaseDirectory.py", line 479, in editEntry
    self._editEntry(entry, check_acls=True)
  File "/home/zopes/intranet.nuxeo/Products/CPSDirectory/BaseDirectory.py", line 489, in _editEntry
    self.checkEditEntryAllowed(id=id, entry=dm_entry)
  File "/home/zopes/intranet.nuxeo/Products/CPSDirectory/BaseDirectory.py", line 311, in checkEditEntryAllowed
    raise Unauthorized("No edit access to entry '%s'" % id)
Unauthorized: No edit access to entry 'fguillaume'

The problem is the editEntry instead of _editEntry

Change History

comment:1 Changed 14 years ago by fguillaume

  • Status changed from new to assigned
  • Description modified (diff)

comment:2 Changed 14 years ago by fguillaume

  • Status changed from assigned to new
  • Owner fguillaume deleted

comment:3 Changed 14 years ago by fguillaume

  • Owner set to fguillaume
  • Status changed from new to assigned

comment:4 Changed 14 years ago by fguillaume

Was fixed in [29541].

comment:5 Changed 14 years ago by fguillaume

  • Status changed from assigned to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.