Ticket #1159 (closed defect: fixed)

Opened 14 years ago

Last modified 14 years ago

portal_widget_types error editing a document type

Reported by: sschintu Owned by: tziade
Priority: P1 Milestone: CPS 3.4.0
Component: CPSTypeMaker Version: TRUNK
Severity: critical Keywords:
Cc:

Description

When I try to edit a document type with CPSTypeMaker I get the following error:

Request URL  http://localhost:8080/cps/cpstypes_edit Exception Type AttributeError? Exception Value portal_widget_types

Traceback (innermost last):

  • Module ZPublisher.Publish, line 113, in publish
  • Module ZPublisher.mapply, line 88, in mapply
  • Module ZPublisher.Publish, line 40, in call_object
  • Module Shared.DC.Scripts.Bindings, line 311, in call
  • Module Shared.DC.Scripts.Bindings, line 348, in _bindAndExec
  • Module Products.CMFCore.FSPageTemplate, line 188, in _exec
  • Module Products.CMFCore.FSPageTemplate, line 127, in pt_render
  • Module Products.PageTemplates.PageTemplate?, line 104, in pt_render <FSPageTemplate at /cps/cpstypes_edit>
  • Module TAL.TALInterpreter, line 206, in call
  • Module TAL.TALInterpreter, line 250, in interpret
  • Module TAL.TALInterpreter, line 477, in do_setLocal_tal
  • Module Products.PageTemplates.TALES, line 221, in evaluate URL: file:CPSTypeMaker/skins/cps_typemaker/cpstypes_edit.pt Line 1, Column 0 Expression: standard:'here/portal_widget_types' Names:

{'container': <CPSDefaultSite at /cps>,

'context': <CPSDefaultSite at /cps>, 'default': <Products.PageTemplates.TALES.Default instance at 0xb76caa2c>, 'here': <CPSDefaultSite at /cps>, 'loop': <Products.PageTemplates.TALES.SafeMapping? object at 0xb29e2fac>, 'modules': <Products.PageTemplates.ZRPythonExpr._SecureModuleImporter instance at 0xb76dc92c>, 'nothing': None, 'options': {'args': ()}, 'repeat': <Products.PageTemplates.TALES.SafeMapping? object at 0xb29e2fac>, 'request': <HTTPRequest, URL= http://localhost:8080/cps/cpstypes_edit>, 'root': <Application at >, 'template': <FSPageTemplate at /cps/cpstypes_edit>, 'traverse_subpath': [], 'user': lp-admin}

AttributeError?: portal_widget_types

Change History

comment:1 Changed 14 years ago by fguillaume

Can you try removing the line mentioning 'wttool' in the template and report if it works?

comment:2 Changed 14 years ago by fguillaume

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in [29954].

Note: See TracTickets for help on using tickets.