Ticket #1166 (closed defect: fixed)

Opened 14 years ago

Last modified 14 years ago

No more rss and atom exports in folder_view

Reported by: bdelbosc Owned by: jmorliaguet
Priority: P1 Milestone: CPS 3.4.0
Component: CPSPortlets Version: TRUNK
Severity: normal Keywords: boxless rss atom
Cc:

Description (last modified by madarche) (diff)

No more rss and atom exports in folder_view

It would be nice to have the new solution handles deprecated boxes url feed.

If the solution is to replace the 'custom portlet' with an improved 'content portlet' (that already provides rss and atom exports), this bug depends on #561.

Change History

comment:1 Changed 14 years ago by bdelbosc

s/[561]/#561/

comment:2 Changed 14 years ago by madarche

  • Description modified (diff)

comment:3 Changed 14 years ago by jmorliaguet

I'm adding a display mode called "folder_contents_detailed" in the navigation portlet that will call the legacy macro:

<metal:block use-macro="here/content_lib_display_contents/macros/display_contents" />

this will replace the custom portlet currently used in CPSDefault for displaying folder contents.

RSS / ATOM exports will be displayable too.

comment:4 Changed 14 years ago by jmorliaguet

  • Status changed from new to closed
  • Resolution set to fixed

fixed in [31527], [31528] and [31529]

export buttons are now available as in the content portlet

I'm updating the CPSDefault portlet setup to use the new display mode instead of the portlet_folder_contents custom portlet.

comment:5 Changed 14 years ago by jmorliaguet

  • Status changed from closed to reopened
  • Resolution fixed deleted

the custom 'portlet_folder_contents' needs to be replaced with the naviagation portlet.

comment:6 Changed 14 years ago by ebarroca

  • Status changed from reopened to new
  • Owner changed from jmorliaguet to div

comment:7 Changed 14 years ago by div

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in [33370]

comment:8 Changed 14 years ago by div

  • Status changed from closed to reopened
  • Resolution fixed deleted

RSS feeds are not valid.

comment:9 Changed 14 years ago by jmorliaguet

can you attach the error message?

comment:10 Changed 14 years ago by div

Try to use any exported RSS feed, for instance in /sections/

The problem is that layout_portlet_view renders a <div class="foo"> </div> which breaks the exported XML.

Instead of having:

<?xml version="1.0" encoding="ISO-8859-15"?>
....

we have:

<div class="portlet_foldercontents">
<?xml version="1.0" encoding="ISO-8859-15"?>
....
</div>

So we could have a different layout used for viewing the navigation portlet which checks if the rendered content is XML and skips the <div> creation in this case. Or this could be done even in the layout_portlet_view.

comment:11 Changed 14 years ago by div

  • Status changed from reopened to closed
  • Resolution set to fixed

Fixed in [33452]

comment:12 Changed 14 years ago by jmorliaguet

  • Status changed from closed to reopened
  • Resolution fixed deleted

The RSS feeds still have the <div portlet_... tag>. (Navigation portlet Content portlet)

it is better to fix it in the default portlet layout view than to create a new layout

comment:13 Changed 14 years ago by jmorliaguet

  • Owner changed from div to jmorliaguet
  • Status changed from reopened to new

comment:14 Changed 14 years ago by jmorliaguet

  • Status changed from new to closed
  • Resolution set to fixed

fixed in [33618] and [33619]. (The XML export function is not specific to the Content Portlet or to the Navigation Portlet.)

Note: See TracTickets for help on using tickets.