Ticket #1190 (closed defect: invalid)

Opened 14 years ago

Last modified 14 years ago

Customizable Widget AttributeError aq_parent

Reported by: joseluis.rosa@… Owned by: tziade
Priority: P2 Milestone: CPS 3.4.0
Component: CPSTypeMaker Version: 3.3.8
Severity: normal Keywords:
Cc:

Description

Hello!

I'm creating a new type of content and I need to add labels (without fields) and horizontal lines (hr). This can be done when editing a Collector Document but it's not possible to do it in Type Maker (I believe). I thought the best way would be to create a new type of widget, so that I can take the possibility to configure it through ZMI in Layout Contents (layout position, css class,etc); I also would create a custom render method to show exactly what I want <hr /> or whatever. I was able to do this with a CPS Compound Widget but I think the right way is to use a Customizable Widget. Neverthless, when I try to edit a newly created Customizable Widget I get this error:

#####################################################

Error Type: AttributeError?

Error Value:

aq_parent

Traceback:

Traceback (innermost last):

  • Module ZPublisher.Publish, line 113, in publish
  • Module ZPublisher.mapply, line 88, in mapply
  • Module ZPublisher.Publish, line 40, in call_object
  • Module Products.CPSSchemas.BasicWidgets?, line 2204, in manage_propertiesForm
  • Module Shared.DC.Scripts.Bindings, line 311, in call
  • Module Shared.DC.Scripts.Bindings, line 346, in _bindAndExec
  • Module Shared.DC.Scripts.Bindings, line 1, in ?
  • Module Shared.DC.Scripts.Bindings, line 265, in _getContext

AttributeError?: aq_parent

########################################################

I'm using CPS 3.3.8. Any idea of how to fix this error?

Thank you very much

Change History

comment:1 Changed 14 years ago by fguillaume

  • Priority changed from P1 to P2
  • Owner changed from fguillaume to tziade
  • Component changed from CPSSchemas to CPSTypeMaker
  • Milestone changed from CPS 3.3.8 to CPS 3.4.0

comment:2 Changed 14 years ago by tziade

is this happening when you use the new custom widget within type maker ? if so, in wich screen ? furthermore, if you can send me this widget, i can try to reproduce this problem on my side

comment:3 Changed 14 years ago by tziade

  • Status changed from new to closed
  • Resolution set to invalid
Note: See TracTickets for help on using tickets.