Ticket #1208 (closed defect: fixed)

Opened 14 years ago

Last modified 14 years ago

the migration script should not be run during portal creation

Reported by: jmorliaguet Owned by: trac
Priority: P1 Milestone: CPS 3.4.0
Component: CPSDefault Version: TRUNK
Severity: major Keywords:
Cc:

Description

The upgrade script in CPSDefault is called during the creation of a portal.

This has a side-effect, namely that portlets in the content_well are added twice (once during the portal instanciation and another time during the migration)

This is due to the fact to transactions are commited at the end of the installation process and the portlets are not yet "visible" for the migration script.

A transaction.commit() could be added in the migration script, or better: it should not be run at all since the initial version is CPS3.4.0.

Change History

comment:1 Changed 14 years ago by sfermigier

I believe that the root cause is that there is only one script for install and update.

This was a design mistake.

Hopefully it will be corrected by the CMFSetup migration.

In the meantime I'm trying to fix this by adding a test on is_creation:

if is_creation:

self.doUpgrades(post_update=False)

comment:2 Changed 14 years ago by sfermigier

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in [30676]

Note: See TracTickets for help on using tickets.