Ticket #1335 (closed defect: fixed)

Opened 14 years ago

Last modified 14 years ago

Image and File fields problems

Reported by: fguillaume Owned by: fguillaume
Priority: P1 Milestone: CPS 3.4.0
Component: CPSSchemas Version: 3.3.8
Severity: normal Keywords:
Cc:

Description

There is a bug in the Image / File widget, that will manifest itself when we import or export documents through XML. Today it's a problem for Image portlets I/O, but it would be a problem if we did any other content I/O for documents.

The problem is that in an attached File object (also true for Images), we store two things: the filename in the id field, and a title in the title field. But we really shouldn't change the id, Zope needs an invariant where the id known by an object is the same as the id that the container of the object knows. That's not the case here.

So we have to modify the Image and File widget, to lose one piece of information. We'll keep the title field, we have to decide what to put in it:

  • original filename
  • user title

Change History

comment:1 Changed 14 years ago by fguillaume

  • Status changed from new to closed
  • Resolution set to fixed

Fixed in [32951]. The filename is kept.

If we later need an additional title (for instance for "alt" purposes), this needs to be stored in a new field in the schema.

Note: See TracTickets for help on using tickets.