Ticket #1356 (closed defect: duplicate)

Opened 14 years ago

Last modified 14 years ago

Error importing Portlet Tools: No TI for portal_type 'Custom Portlet'

Reported by: sschintu Owned by: div
Priority: P1 Milestone: CPS 3.4.0
Component: CPSDefault Version: TRUNK
Severity: normal Keywords:
Cc:

Description

When importing the Portlet Tools from portal_setup I get the following error:

An error was encountered while publishing this resource.

Error Type: ValueError? Error Value: No TI for portal_type 'Custom Portlet'

And this is what I found in the event.log:

ERROR Zope.SiteErrorLog?  http://localhost:8080/cps/portal_setup/manage_importSelectedSteps Traceback (most recent call last):

File "/home/zope/z290-p242/lib/python/ZPublisher/Publish.py", line 113, in publish

request, bind=1)

File "/home/zope/z290-p242/lib/python/ZPublisher/mapply.py", line 88, in mapply

if debug is not None: return debug(object,args,context)

File "/home/zope/z290-p242/lib/python/ZPublisher/Publish.py", line 40, in call_object

result=apply(object,args) # Type s<cr> to step into published object.

File "/home/zope/cps-z290-p242/Products/GenericSetup/tool.py", line 417, in manage_importSelectedSteps

result = self.runImportStep(step_id, run_dependencies)

File "/home/zope/cps-z290-p242/Products/GenericSetup/tool.py", line 227, in runImportStep

message = self._doRunImportStep(step_id, context)

File "/home/zope/cps-z290-p242/Products/GenericSetup/tool.py", line 716, in _doRunImportStep

return handler(context)

File "/home/zope/cps-z290-p242/Products/CPSPortlets/exportimport.py", line 94, in importPortletTool

importCPSObjects(root_portlets, , context)

File "/home/zope/cps-z290-p242/Products/CPSDocument/exportimport.py", line 360, in importCPSObjects

importCPSObjects(sub, path+'/', context)

File "/home/zope/cps-z290-p242/Products/CPSDocument/exportimport.py", line 359, in importCPSObjects

for sub in getCPSObjectValues(obj):

File "/home/zope/cps-z290-p242/Products/CPSDocument/exportimport.py", line 303, in getCPSObjectValues

addCPSFieldObjectItems(parent, items)

File "/home/zope/cps-z290-p242/Products/CPSDocument/exportimport.py", line 313, in addCPSFieldObjectItems

datamodel = parent.getDataModel()

File "/home/zope/cps-z290-p242/Products/CPSDocument/CPSDocument.py", line 140, in getDataModel

raise ValueError?("No TI for portal_type %r" % self.portal_type)

ValueError?: No TI for portal_type 'Custom Portlet'

Change History

comment:1 Changed 14 years ago by atchertchian

  • Version changed from 3.0.0 to TRUNK
  • Component changed from CMFNtlmSso to CPSDefault
  • Milestone changed from CPS 3.2.5 to CPS 3.4.0

Need to check if this is now fixed (see #1342)

comment:2 Changed 14 years ago by div

Not fixed yet.

comment:3 Changed 14 years ago by ebarroca

  • Owner changed from trac to div

comment:4 Changed 14 years ago by div

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #1342

Note: See TracTickets for help on using tickets.