Ticket #1552 (closed defect: worksforme)

Opened 14 years ago

Last modified 10 years ago

modifying a portlet does not reset the cache

Reported by: jmorliaguet Owned by: jmorliaguet
Priority: P1 Milestone: CPS 3.4.9
Component: CPSPortlets Version: 3.4.1
Severity: normal Keywords: cache
Cc:

Description

modifying a portlet via cpsportlet_edit.py does not reset the cache on the portlet.

Change History

comment:1 Changed 14 years ago by jmorliaguet

  • Status changed from new to assigned

this is because the form action calls 'cpsdocument_edit' instead of 'cpsportlet_edit'

<form action="cpsdocument_edit" method="post" id="editForm" enctype="multipart/form-data">

comment:2 Changed 14 years ago by jmorliaguet

fixed in [34440]

comment:3 Changed 14 years ago by jmorliaguet

  • Status changed from assigned to closed
  • Resolution set to fixed

comment:4 Changed 13 years ago by tracguest

  • Status changed from closed to reopened
  • Version changed from 3.4.0 to 3.4.1
  • Resolution fixed deleted

Sorry, but I think the problem is still there.

Changes in a text portlet don't show up until I purge the cache in ZMI.

In one site I had a similar problem with the sort order in a content portlet. The funny thing was, it worked fine in another site running on the same zope instance.

comment:5 Changed 10 years ago by gracinet

  • Milestone changed from CPS 3.4.1 to CPS 3.4.9

Buried ticket. Updated milestone

comment:6 Changed 10 years ago by gracinet

  • Status changed from reopened to closed
  • Resolution set to worksforme

Tested on a fresh CPS 3.4 site, works. Either this was fixed long ago, or this is related to subtle invalidaion problems. As a side note, one can see events occurring and cache misses in the debug level logs of CPSPortlets.

Note: See TracTickets for help on using tickets.