Ticket #1644 (reopened defect)

Opened 13 years ago

Last modified 13 years ago

epoz still called over cpswiki

Reported by: tziade Owned by: madarche
Priority: P2 Milestone: CPS 3.5.7
Component: CPSWiki Version: 3.4.1
Severity: normal Keywords:
Cc:

Description

Error Type:  	AttributeError
Error Value: 	

Epoz

Traceback: 	

Traceback (innermost last):

    * Module ZPublisher.Publish, line 114, in publish
    * Module ZPublisher.mapply, line 88, in mapply
[..]
    * Module TAL.TALInterpreter, line 647, in do_insertStructure_tal
    * Module Products.PageTemplates.TALES, line 221, in evaluate
      URL: file:CPSWiki/skins/cps_wiki/cps_wiki_pageedit.pt
      Line 28, Column 8
      Expression: <PythonExpr here.Epoz( name='source', data=source, lang='en',
style='width: 100%; height: 300px; border: 1px solid #a0a0a0; border-style:
solid;')>
      Names:

      {'container': <CPSDefaultSite at /spptest5>,
       'context': <WikiPage at /spptest5/workspaces/my_wiki/test1>,
       'default': <Products.PageTemplates.TALES.Default instance at 0x40de5a6c>,
       'here': <WikiPage at /spptest5/workspaces/my_wiki/test1>,
       'loop': <Products.PageTemplates.TALES.SafeMapping object at 0x4729d94c>,
       'modules': <Products.PageTemplates.ZRPythonExpr._SecureModuleImporter
instance at 0x40e169cc>,
       'nothing': None,
       'options': {'args': ()},
       'repeat': <Products.PageTemplates.TALES.SafeMapping object at
0x4729d94c>,
       'request': <HTTPRequest,
URL=http://server1.smartpm:9677/spptest5/workspaces/my_wiki/test1/cps_wiki_pagee
dit>,
       'root': <Application at >,
       'template': <FSPageTemplate at /spptest5/cps_wiki_pageedit used for
/spptest5/workspaces/my_wiki/test1>}

    * Module Products.PageTemplates.ZRPythonExpr, line 47, in __call__
      __traceback_info__: here.Epoz( name='source', data=source, lang='en',
style='width: 100%; height: 300px; border: 1px solid #a0a0a0; border-style:
solid;')
    * Module Python expression "here.Epoz( name='source', data=source,
lang='en', style='width: 100%; height: 300px; border: 1px solid #a0a0a0;
border-style: solid;')", line 1, in <expression>

Change History

comment:1 Changed 13 years ago by sfermigier

  • Owner changed from tziade to madarche

tziade says madarche will try to fix it.

comment:2 Changed 13 years ago by sfermigier

  • Priority changed from P2 to P1
  • Severity changed from normal to major
  • Milestone changed from CPS 3.4.1 to CPS 3.4.2

comment:3 Changed 13 years ago by tracguest

But unfortunately not even epoz pops up. From my point of view, get an wysiwyg editor working for CPSwiki is urgent and critical.

comment:4 Changed 13 years ago by madarche

  • Status changed from new to closed
  • Resolution set to fixed

Made CPSWiki use FCKeditor.

Fixed in changeset [47536].

comment:5 Changed 13 years ago by tracguest

  • Status changed from closed to reopened
  • Resolution fixed deleted

I changed the .pt and import the CPSWiki profile -> The corrected .pt is shown in ZMI.

But still I can't see a possibility to use FCKeditor to edit edit pages of html parsed CPSWiki.

comment:6 Changed 13 years ago by madarche

  • Priority changed from P1 to P2
  • Severity changed from major to normal

First, have you try to clear the JavaScript? cache of your navigator ?

Second what is your configuration (OS and navigator) ?

I have tested the result of my fix with a brand new CPS from the trunk. So I suggest you to do a fresh checkout of the CPS code from the trunk, then instantiate a CPS site and finally create your wiki and wiki pages. Then you will be able to test the fix and report here if it works on a plain CPS and we will close this bug.

Once you have your new working CPS site you will be able to compare it with your actual CPS site and find more easily why FCKeditor doesn't show up for you.

Finally, in the ZMI, have you got an FckHTTPCache object at the root of your CPS site ?

comment:7 Changed 13 years ago by tracguest

  • Version changed from 3.4.0 to 3.4.1

Cache cleared.

Firefox on WinXP

It works in the page after action "Add page" or "edit".

FCKeditor does not show after clicking the edit Icon in upper right corner.

comment:8 Changed 13 years ago by tracguest

The edit action shows a FCKeditor. But it is always empty even if the page already contained text.

Note: See TracTickets for help on using tickets.