Ticket #1755 (new defect)

Opened 13 years ago

CPSCompat/ExternalEditor and Zope 2.10: ZMI not working

Reported by: ybastide Owned by: fguillaume
Priority: P2 Milestone:
Component: CPSCompat Version: TRUNK
Severity: normal Keywords:
Cc:

Description

There's a bug in ExternalEditor?'s manage_main.dtml, mirrored in CPSCompat: the use of aq_self wherer aq_explicit is needed. under Zope 2.10, this prevents the ZMI from working.

The diff can be seen at  http://svn.zope.org/Products.ExternalEditor/trunk/manage_main.dtml?rev=69920&r1=67548&r2=69920

It needs to be applied to CPSCompat/manage_main.dtml too. An,d I guess the ExternalEditor? included in CPS should be upgraded too

yves

Note: See TracTickets for help on using tickets.