Ticket #2158 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

AssertionError: stylesheet and stylesheet_path are mutually exclusive

Reported by: madarche Owned by: tziade
Priority: P2 Milestone: CPS 3.5.0
Component: CPSWiki Version: TRUNK
Severity: normal Keywords:
Cc:

Description (last modified by madarche) (diff)

The problem is only found on system having docutils python software installed. For example on Debian its the "python-docutils" package.

Change History

comment:1 Changed 9 years ago by madarche

  • Status changed from new to closed
  • Resolution set to fixed
  • Description modified (diff)

This was due to an incompatibility of The Zope docutils wrapper and the installed version of docutils. The Zope docutils wrapper was setting the "stylesheet" option by default. The solution was to explicitely disable the "stylesheet" option in the CPS code, option that we don't need anyway since the styling is done in the CPS theme engine.

Pushed  http://hg.cps-cms.org/

Note: See TracTickets for help on using tickets.