Ticket #2179 (closed defect: fixed)

Opened 9 years ago

Last modified 9 years ago

Unicode upgrade step for workflow transition comments

Reported by: gracinet Owned by: janguenot
Priority: P1 Milestone: CPS 3.5.1
Component: CPSWorkflow Version: TRUNK
Severity: minor Keywords: commments workflow transition
Cc:

Description

If one submits a document, while entering a comment with non-ascii chars, this ends up as an UnicodeDecodeError? in CPSSubscriptions. The origin of the problem is the comments string not being unicode ready : it's stored encoded.

This means that a few templates (content_transition_form etc) will have to be checked and fixed. and furthermore that we'll need an upgrade step for workflow history.

Using the global component for this ticket, because templates involving comments can occur in lots of products (CPSDefault being the first, obvious, one)

Change History

comment:1 Changed 9 years ago by gracinet

  • Owner changed from madarche to janguenot
  • Component changed from CPS (global) to CPSWorkflow
  • Severity changed from critical to minor
  • Summary changed from Workflow transition comments not ready for unicode to Unicode upgrade step for workflow transition comments

Actually the problem I got through was an due to an override in a custom project. The upgrade step is still needed, though.

comment:2 Changed 9 years ago by gracinet

  • Status changed from new to closed
  • Resolution set to fixed

Done and pushed. This affects primarily CPSWorkflow, but is also registered in CPSDefault big job (see #2184) and uses new walking utilities in CPSCore as well.

Note: See TracTickets for help on using tickets.