Ticket #2207 (new defect)

Opened 9 years ago

update-clones and subbundles

Reported by: gracinet Owned by: gracinet
Priority: P2 Milestone: unspecified
Component: hgutils Version: TRUNK
Severity: normal Keywords:
Cc:

Description

hgbundler update-clones does not automatically pull on sub bundles. This is consistent with the principle that hgbundler commands don't perform any push or pull.

So far, so good, but this ends up in error if one wants to use a new sub bundle branch (such as the current future-3.5.2). There should be an explicit warning instead, suggesting the pull to the user.

Note: See TracTickets for help on using tickets.