Ticket #2243 (closed defect: duplicate)

Opened 9 years ago

Last modified 9 years ago

Refactor portlets syndication feeds

Reported by: gracinet Owned by: gracinet
Priority: P2 Milestone: CPS 3.5.2
Component: CPSPortlets Version: 3.5.1rc2
Severity: normal Keywords:
Cc:

Description

Right now, the rendering of a Content or Navigation portlet as a syndication feed is done as a normal rendering, ie, ie as a CPSDocument, with tal:condition to check for the export keyword.

This is a waste of resources, a source of regressions, especially since a single leading empty line makes an XML file invalid, and that's terribly hard to enforce within ZPTs.

We should instead use elementtree to provide those feeds instead and bypass the document/layouts machinery. Keeping the cache is a good idea, though.

Change History

comment:1 Changed 9 years ago by gracinet

  • Milestone changed from CPS 3.5.1 to CPS 3.5.2

comment:2 Changed 9 years ago by gracinet

  • Status changed from new to closed
  • Resolution set to duplicate

Issue treated in #2283

Note: See TracTickets for help on using tickets.