Ticket #2287 (new defect)

Opened 9 years ago

Last modified 9 years ago

Stop providing Five 1.3.2

Reported by: gracinet Owned by: gracinet
Priority: P2 Milestone: CPS 3.5.7
Component: CPS (global) Version: 3.5.1
Severity: normal Keywords:
Cc:

Description

Since the early days of Zope 2.9, CPS has been shipping with a specific Five version (currently 1.3.2). At that time, Five was not really stable yet, and providing it was a way to get those needed bugfixes ahead of Zope. At least, that's what the svn log of the bundle suggests :

svn log http://svn.nuxeo.org/pub/CPS3/bundles/CPS-3-full

It turns out that the version we provide (Five 1.3.2) has been incorporated in Zope for Zope 2.9.2. We currently require Zope 2.9. >= 2.9.7 and frequently run on Zope 2.9.10-2.9.12. The latter has Five 1.3.11

Further, it is very unlikely that this Five 1.3.2 could work on Zope 2.10 (preliminary tests were done without it, of course), and even if it did, this would really become a hazard.

For uniformity of CPS on both Zope 2.9 and 2.10, it's better to remove Five from the bundle. The releases should be identical if possible for both Zope versions

Change History

comment:1 Changed 9 years ago by gracinet

Tried to launch the tests on Five version provided by Zope 2.9.12, and got basically the same errors as on Zope 2.10.12 (before the fixes made in branch). This looks good.

Note: See TracTickets for help on using tickets.