Ticket #829 (closed defect: fixed)

Opened 14 years ago

Last modified 14 years ago

Differences in history are not readable

Reported by: laurent.pelecq@… Owned by: tziade
Priority: P2 Milestone: CPS 3.3.7
Component: CPSWiki Version: TRUNK
Severity: normal Keywords:
Cc:

Description

Differences are in history are displayed without newlines.

It would be better to use <pre> instead of <p> in cps_wiki_differences.pt. It makes the result readable.

Change History

comment:1 Changed 14 years ago by fguillaume

  • Priority changed from P1 to P2
  • Milestone changed from CPS 3.2.5 to CPS 3.3.6

comment:2 Changed 14 years ago by fguillaume

  • Milestone changed from CPS 3.3.6 to CPS 3.4.0

comment:3 Changed 14 years ago by lregebro

  • Status changed from new to closed
  • Resolution set to fixed

Three separate reasons for unreadanility fixed:

  1. The above mentioned pre instead of p tag.
  2. If the version did not end in a new-line, the next line would be tagged onto that line.
  3. The python difflib inserts lines that highlight what changed when things inside a line changed. So far so good, but it starts these lines with a '?', which to most normal people means that there is something questionable going on. Hence, we switch that out for a '>' character instead, which does not carry any such connotations.

I view the last two things as bugs in the diff-lib, actually, but we still need to work around them. I did that in revision [28512].

comment:4 Changed 14 years ago by lregebro

I changed my mind. 2. is not a bug in difflib after all. :)

  1. Continues to be a misfeature, though.
Note: See TracTickets for help on using tickets.