Ticket #873 (closed defect: wontfix)

Opened 14 years ago

Last modified 14 years ago

CPSInstaller.setupProduct should be able to handle the reinstall case with CMFQuickInstaller

Reported by: dw@… Owned by: trac
Priority: P1 Milestone: CPS 3.4.0
Component: CPSInstaller Version: CPS 3.3 branch
Severity: normal Keywords:
Cc:

Description

In CPSInstaller, runExternalUpdater does the following : if not qtool.isProductInstalled(module):

qtool_res = qtool.installProduct(module) self.log("Product %s: %s"%(module, qtool_res,)) return

So if the product is already installed, this code is not run, and we skip to the second part of the method, creating an external method and running it. We lose partly the handling of this product by CMFQuickInstaller!

In the case of isProductInstalled returning True, we should simple try to call reinstallProducts of CMFQuickInstaller.

Change History

comment:1 Changed 14 years ago by atchertchian

See #493, Lennart and I had a discussion about this.

comment:2 Changed 14 years ago by fguillaume

Hopefully this all goes away when #586 (CMFSetup) is done.

comment:3 Changed 14 years ago by tziade

  • Milestone changed from CPS 3.4.0 to CPS 3.4.1

moved to 3.4.1

comment:4 Changed 14 years ago by fguillaume

#1084 was a duplicate of this bug.

comment:5 Changed 14 years ago by fguillaume

  • Status changed from new to closed
  • Resolution set to wontfix
  • Milestone changed from CPS 3.4.1 to CPS 3.4.0

CPSInstaller is obsolete.

Note: See TracTickets for help on using tickets.