Ticket #930 (closed defect: fixed)

Opened 14 years ago

Last modified 14 years ago

Type maker exception when a user modify a component

Reported by: y.boussard@… Owned by: tziade
Priority: P2 Milestone: CPS 3.3.7
Component: CPSTypeMaker Version: 3.3.5
Severity: minor Keywords:
Cc:

Description

to reproduce the problem :

1 create a new content type via tyme maker interface 2 create a new field 3 uncheck view display

you have the error :

Request URL  http://localhost:10080/catalogue/portal_typemaker/portal_typemaker/manage_documentModified Exception Type TypeError? Exception Value can only concatenate list (not "tuple") to list

Traceback (innermost last):

  • Module ZPublisher.Publish, line 101, in publish
  • Module ZPublisher.mapply, line 88, in mapply
  • Module ZPublisher.Publish, line 39, in call_object
  • Module Products.CPSTypeMaker.TypeMakerTool?, line 336, in manage_documentModified
  • Module Products.CPSTypeMaker.TypeMakerTool?, line 1332, in _updateWidget

TypeError?: can only concatenate list (not "tuple") to list

proposed solution:

replace in TypesMarkerTool? line 1332 kwhidden_layout_modes? = view?+ self.hidden_layout_modes

by

kwhidden_layout_modes? = view?+list(self.hidden_layout_modes)

this work for me

Change History

comment:1 Changed 14 years ago by fguillaume

  • Priority changed from P1 to P2
  • Version changed from 3.0.0 to 3.3.5
  • Milestone changed from CPS 3.3.5 to CPS 3.4.0

I'd rather convert everything to tuples. Tuples are the standard storage mode for properties that are sequences since Zope 2.7.

comment:2 Changed 14 years ago by lregebro

  • Status changed from new to closed
  • Resolution set to fixed

This field is now always converted to tuples when you change this. Revision [28648].

Note: See TracTickets for help on using tickets.